# Application Security Supported Fields

This document shows the fields supported by each provider and operation.

- [get_application_finding_details](#get_application_finding_details)
- [query_application_findings](#query_application_findings)
- [query_applications](#query_applications)
- [query_findings](#query_findings)


## get_application_finding_details

| Field | Amazon Inspector | GitHub | GitLab | HCL AppScan on Cloud | OpenText Application Security (On-Premise) | OpenText Core Application Security | Snyk | Type |
|  --- | --- | --- | --- | --- | --- | --- | --- | --- |
| activity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| activity_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.data.src_url | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | string |
| application.data.type_alt | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.name | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| application.src_url | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.type | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.uid_alt | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.hostname | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.path | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.scheme | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.url_string | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| category_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| category_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| class_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| class_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| compliance.requirements[] | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| compliance.standards[] | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| confidence | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| confidence_score | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | number |
| finding_info.first_seen_time | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | timestamp |
| finding_info.last_seen_time | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | timestamp |
| finding_info.modified_time | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | timestamp |
| finding_info.product.name | ❌ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| finding_info.product.uid | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.vendor_name | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.version | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.src_url | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | string |
| finding_info.title | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | string |
| finding_info.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| finding_info.uid_alt | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | ❌ | string |
| finding_info.xattributes.publicly_leaked | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | boolean |
| finding_info.xattributes.secret_type | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.xattributes.validity | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| message | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | string |
| metadata.labels[] | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| metadata.product.feature.name | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| metadata.product.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.product.vendor_name | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.tenant_uid | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| metadata.version | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].type | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].type_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| observables[].value | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| remediation.desc | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ❌ | string |
| remediation.kb_article_list[].classification | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| remediation.kb_article_list[].src_url | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| remediation.kb_article_list[].title | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| remediation.kb_article_list[].uid | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| remediation.references[] | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| risk_details | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| risk_score | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| severity | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| severity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| status | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | string |
| status_code | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| status_detail | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| status_id | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | number |
| time | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| timezone_offset | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| type_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| type_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| vulnerabilities[].advisory.created_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | timestamp |
| vulnerabilities[].advisory.desc | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].advisory.modified_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| vulnerabilities[].advisory.references[] | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].base_score | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].advisory.related_cves[].cvss[].overall_score | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].advisory.related_cves[].cvss[].severity | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].vector_string | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].vendor_name | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].version | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].epss.percentile | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].advisory.related_cves[].epss.score | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].modified_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| vulnerabilities[].advisory.related_cves[].references[] | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].uid | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cwes[].caption | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cwes[].src_url | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cwes[].uid | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.src_url | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.uid | ❌ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].end_column | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].affected_code[].end_line | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | ✅ | number |
| vulnerabilities[].affected_code[].file.ext | ❌ | ✅ | ❌ | ❌ | ✅ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.path | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.type | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.type_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| vulnerabilities[].affected_code[].file.uri | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.desc | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].affected_code[].rule.name | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].affected_code[].rule.uid | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | ❌ | string |
| vulnerabilities[].affected_code[].start_column | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].affected_code[].start_line | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| vulnerabilities[].affected_packages[].epoch | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_packages[].fixed_in_version | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].affected_packages[].name | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].affected_packages[].package_manager | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].path | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].version | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].category | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.created_time | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | timestamp |
| vulnerabilities[].cve.cvss[].base_score | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].cve.cvss[].vector_string | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.cvss[].vendor_name | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.cvss[].version | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.epss.percentile | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].cve.epss.score | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.references[] | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.related_cwes[].src_url | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].cve.related_cwes[].uid | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].cve.uid | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].cwe.src_url | ❌ | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cwe.uid | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].desc | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | ❌ | string |
| vulnerabilities[].exploit_maturity_levels[].cvss_version | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].exploit_maturity_levels[].value | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].fix_coverage | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].fix_coverage_id | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].is_exploit_available | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | boolean |
| vulnerabilities[].is_fix_available | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | boolean |
| vulnerabilities[].is_reachable | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | boolean |
| vulnerabilities[].references[] | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].title | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |


## query_application_findings

| Field | Amazon Inspector | GitHub | GitLab | HCL AppScan on Cloud | OpenText Application Security (On-Premise) | OpenText Core Application Security | ServiceNow Application Vulnerability Response | Snyk | Veracode | Type |
|  --- | --- | --- | --- | --- | --- | --- | --- | --- | --- | --- |
| activity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| activity_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.data.scanned_ci | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| application.data.scanned_ci_name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| application.data.src_url | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| application.data.type_alt | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.desc | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| application.name | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| application.src_url | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.type | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.uid_alt | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.hostname | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| application.url.path | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| application.url.port | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| application.url.query_string | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| application.url.scheme | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| application.url.url_string | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| category_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| category_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| class_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| class_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| compliance.requirements[] | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| compliance.standards[] | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| finding_info.created_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | timestamp |
| finding_info.created_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| finding_info.data_sources[] | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| finding_info.first_seen_time | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | timestamp |
| finding_info.first_seen_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| finding_info.last_seen_time | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | timestamp |
| finding_info.last_seen_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| finding_info.modified_time | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | ❌ | timestamp |
| finding_info.modified_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| finding_info.product.name | ❌ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.uid | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.vendor_name | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.version | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.src_url | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| finding_info.title | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | string |
| finding_info.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| finding_info.uid_alt | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| finding_info.xattributes.publicly_leaked | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | boolean |
| finding_info.xattributes.secret_type | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.xattributes.validity | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| message | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| metadata.product.feature.name | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| metadata.product.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.product.vendor_name | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.tenant_uid | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| metadata.version | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].type | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].type_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| observables[].value | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| remediation.desc | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| remediation.references[] | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| risk_score | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | ❌ | number |
| severity | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| severity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| status | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| status_code | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| status_detail | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| status_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| time | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| timezone_offset | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| type_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| type_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| vulnerabilities[].advisory.created_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | timestamp |
| vulnerabilities[].advisory.desc | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.modified_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | timestamp |
| vulnerabilities[].advisory.references[] | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].base_score | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | number |
| vulnerabilities[].advisory.related_cves[].cvss[].overall_score | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].advisory.related_cves[].cvss[].severity | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].vector_string | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].vendor_name | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].version | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].epss.percentile | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].advisory.related_cves[].epss.score | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].modified_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | timestamp |
| vulnerabilities[].advisory.related_cves[].references[] | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].uid | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.related_cwes[].caption | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cwes[].src_url | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cwes[].uid | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.src_url | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.title | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].advisory.uid | ❌ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | string |
| vulnerabilities[].affected_code[].end_column | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | number |
| vulnerabilities[].affected_code[].end_line | ✅ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | number |
| vulnerabilities[].affected_code[].file.ext | ❌ | ✅ | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].affected_code[].file.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.path | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.type | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].file.type_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | number |
| vulnerabilities[].affected_code[].file.uri | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.desc | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.name | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.uid | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].start_column | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | number |
| vulnerabilities[].affected_code[].start_line | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | number |
| vulnerabilities[].affected_package[].name | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_package[].purl | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_package[].version | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].epoch | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_packages[].fixed_in_version | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].affected_packages[].license | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].affected_packages[].name | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | string |
| vulnerabilities[].affected_packages[].package_manager | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].path | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].purl | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].type | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].type_id | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_packages[].uid | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].affected_packages[].version | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | string |
| vulnerabilities[].category | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.created_time | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | timestamp |
| vulnerabilities[].cve.cvss[].base_score | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].cve.cvss[].severity | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.cvss[].vector_string | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.cvss[].vendor_name | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.cvss[].version | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.epss.percentile | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].cve.epss.score | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.epss.version | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.references[] | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cve.related_cwes[].src_url | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.related_cwes[].uid | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.uid | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cwe.caption | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cwe.src_url | ❌ | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].cwe.uid | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].exploit_maturity_levels[].cvss_version | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].exploit_maturity_levels[].value | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].fix_coverage | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].fix_coverage_id | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | number |
| vulnerabilities[].is_exploit_available | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | boolean |
| vulnerabilities[].is_fix_available | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | boolean |
| vulnerabilities[].is_reachable | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | boolean |
| vulnerabilities[].references[] | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |


## query_applications

| Field | Amazon Inspector | GitHub | GitLab | HCL AppScan on Cloud | OpenText Application Security (On-Premise) | OpenText Core Application Security | ServiceNow Application Vulnerability Response | Snyk | Veracode | Type |
|  --- | --- | --- | --- | --- | --- | --- | --- | --- | --- | --- |
| activity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| activity_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.created_time | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | timestamp |
| application.created_time_dt | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.criticality | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ✅ | string |
| application.desc | ❌ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | ❌ | ❌ | string |
| application.first_seen_time | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | timestamp |
| application.first_seen_time_dt | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.group.desc | ❌ | ❌ | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| application.group.domain | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.group.name | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| application.group.type | ❌ | ❌ | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | string |
| application.group.uid | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| application.modified_time | ❌ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | timestamp |
| application.modified_time_dt | ❌ | ✅ | ✅ | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | string |
| application.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.owner.uid | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | string |
| application.risk_level | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| application.risk_level_id | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| application.risk_score | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| application.src_url | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| application.tags[].name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | string |
| application.tags[].value | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | string |
| application.type | ✅ | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ✅ | ❌ | string |
| application.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.uid_alt | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.url_string | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| category_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| category_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| class_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| class_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| criticality | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ✅ | string |
| data.findings_count | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| data.first_seen_time | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | timestamp |
| data.git_repo_url | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.last_completed_scan_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| data.last_policy_compliance_check_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| data.modified_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| data.policy.compliance_status | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.policy.name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.policy.uid | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.scan_activities[].activity_id | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| data.scan_activities[].category_uid | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| data.scan_activities[].class_uid | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| data.scan_activities[].scan.name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.scan_activities[].scan.uid | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.scan_activities[].status | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| data.scan_activities[].time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| data.scan_activities[].type_uid | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| data.severity_count.critical | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | ❌ | number |
| data.severity_count.high | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | ❌ | number |
| data.severity_count.informational | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| data.severity_count.low | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | ❌ | number |
| data.severity_count.medium | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | ❌ | number |
| data.severity_count.unknown | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| data.src_url | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| data.target_reference | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| data.type_alt | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| desc | ❌ | ✅ | ✅ | ❌ | ✅ | ✅ | ❌ | ❌ | ❌ | string |
| group.desc | ❌ | ❌ | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| group.domain | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| group.name | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| group.type | ❌ | ❌ | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | string |
| group.uid | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| metadata.extensions[].name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.extensions[].uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.extensions[].version | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.product.feature.name | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| metadata.product.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.product.vendor_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.profiles[] | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.version | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| owner.uid | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | string |
| risk_level | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| risk_level_id | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| risk_score | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | number |
| severity | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| severity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| tags[].name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | string |
| tags[].value | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | string |
| time | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| time_dt | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| timezone_offset | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| type | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| type_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| type_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| uid_alt | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| url.hostname | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| url.path | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| url.scheme | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| url.url_string | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ✅ | string |


## query_findings

| Field | Amazon Inspector | GitHub | GitLab | HCL AppScan on Cloud | OpenText Application Security (On-Premise) | OpenText Core Application Security | ServiceNow Application Vulnerability Response | Snyk | Type |
|  --- | --- | --- | --- | --- | --- | --- | --- | --- | --- |
| activity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| activity_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.criticality | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| application.data.findings_count | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ❌ | number |
| application.data.first_seen_time | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | timestamp |
| application.data.scanned_ci | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| application.data.scanned_ci_name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| application.data.severity_count.critical | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | number |
| application.data.severity_count.high | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | number |
| application.data.severity_count.informational | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ❌ | number |
| application.data.severity_count.low | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | number |
| application.data.severity_count.medium | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | ❌ | ✅ | number |
| application.data.severity_count.unknown | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| application.data.src_url | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | string |
| application.data.target_reference | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| application.data.type_alt | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.desc | ❌ | ✅ | ❌ | ❌ | ✅ | ✅ | ✅ | ❌ | string |
| application.first_seen_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | timestamp |
| application.group.desc | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| application.group.domain | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.group.name | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | string |
| application.group.type | ❌ | ❌ | ✅ | ❌ | ✅ | ✅ | ❌ | ✅ | string |
| application.group.uid | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | string |
| application.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.owner.uid | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| application.risk_level | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| application.risk_level_id | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | number |
| application.risk_score | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | number |
| application.src_url | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.type | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | ❌ | ✅ | string |
| application.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| application.uid_alt | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.hostname | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.path | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.scheme | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| application.url.url_string | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| category_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| category_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| class_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| class_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| finding_info.created_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | timestamp |
| finding_info.created_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| finding_info.data_sources[] | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| finding_info.first_seen_time | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | timestamp |
| finding_info.first_seen_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| finding_info.last_seen_time | ✅ | ❌ | ❌ | ✅ | ❌ | ✅ | ✅ | ❌ | timestamp |
| finding_info.last_seen_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| finding_info.modified_time | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | ✅ | timestamp |
| finding_info.modified_time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| finding_info.product.name | ❌ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.uid | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.vendor_name | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.product.version | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.src_url | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | string |
| finding_info.title | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ✅ | ✅ | string |
| finding_info.uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| finding_info.uid_alt | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | string |
| finding_info.xattributes.publicly_leaked | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | boolean |
| finding_info.xattributes.secret_type | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| finding_info.xattributes.validity | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| message | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| metadata.product.feature.name | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| metadata.product.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.product.vendor_name | ✅ | ❌ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| metadata.tenant_uid | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| metadata.version | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].type | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| observables[].type_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| observables[].value | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| remediation.desc | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| remediation.references[] | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| risk_score | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | number |
| severity | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| severity_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| status | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| status_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| time | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| time_dt | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| timezone_offset | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| type_name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | string |
| type_uid | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | number |
| vulnerabilities[].advisory.created_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | timestamp |
| vulnerabilities[].advisory.desc | ❌ | ❌ | ❌ | ❌ | ✅ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].advisory.modified_time | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| vulnerabilities[].advisory.references[] | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].base_score | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].advisory.related_cves[].cvss[].severity | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].vector_string | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].vendor_name | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].cvss[].version | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].epss.percentile | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].advisory.related_cves[].epss.score | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cves[].modified_time | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | timestamp |
| vulnerabilities[].advisory.related_cves[].references[] | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cves[].uid | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.related_cwes[].caption | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].advisory.related_cwes[].uid | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].advisory.title | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | ❌ | string |
| vulnerabilities[].advisory.uid | ❌ | ✅ | ❌ | ❌ | ✅ | ✅ | ✅ | ✅ | string |
| vulnerabilities[].affected_code[].end_column | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_code[].end_line | ✅ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_code[].file.ext | ❌ | ✅ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].file.name | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].file.path | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].file.type | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].file.type_id | ✅ | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | number |
| vulnerabilities[].affected_code[].file.uri | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.desc | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.name | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].rule.uid | ✅ | ✅ | ❌ | ❌ | ✅ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].affected_code[].start_column | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_code[].start_line | ✅ | ✅ | ✅ | ✅ | ✅ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].affected_packages[].fixed_in_version | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].affected_packages[].name | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].affected_packages[].package_manager | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].path | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].affected_packages[].version | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].category | ❌ | ❌ | ❌ | ✅ | ❌ | ✅ | ❌ | ❌ | string |
| vulnerabilities[].cve.created_time | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | timestamp |
| vulnerabilities[].cve.cvss[].base_score | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | number |
| vulnerabilities[].cve.cvss[].version | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.references[] | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.related_cwes[].src_url | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.related_cwes[].uid | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cve.uid | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cwe.src_url | ❌ | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].cwe.uid | ✅ | ✅ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | string |
| vulnerabilities[].exploit_maturity_levels[].cvss_version | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].exploit_maturity_levels[].value | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].fix_coverage | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | string |
| vulnerabilities[].fix_coverage_id | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | number |
| vulnerabilities[].is_exploit_available | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | boolean |
| vulnerabilities[].is_fix_available | ❌ | ❌ | ✅ | ❌ | ❌ | ❌ | ❌ | ✅ | boolean |
| vulnerabilities[].is_reachable | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ❌ | ✅ | boolean |